.htaccess ile Php Sürüm Değişimi

Merhaba herkese uzun bir zaman sonra bu ilk yazımda müşterime ait wordpress sitesinin başka sunucuya geçerken yaşadığım uyumsuzluğu çözüm yolumu anlatacağım.

Bildiğiniz üzere WordPress Php diliyle yazılmış bir dildir ve php’de geliştirmeler farklı sürümlerle toplu bir şekilde yapılır. Bazı wordpress eklentileri ise php sürümüne göre çalıştığından herhangi bir sürüm uyuşmazlığı durumunda siteniz 500 hatası verebilmektedir.

Bu değişikliği cpanel üzerinden multiphp fonksiyonuyla kolayca çözebilirisiniz fakat cpanel kullanılmayan sunucularda çözümü elle yapmanız gerekmektedir.

Yapmanız gereken ise aşağıdaki php sürüm değişiklik kodlarını .htaccess dosyasına işlemektir.

PHP 4.4 Sürümüne geçmek için:
AddHandler application/x-httpd-php4 .php .php4 .php3

PHP 5.0 Sürümüne geçmek için:
AddHandler application/x-httpd-php5 .php .php4 .php3

PHP 5.1 Sürümüne geçmek için:
AddHandler application/x-httpd-php51 .php .php4 .php3

PHP 5.2 Sürümüne geçmek için:
AddHandler application/x-httpd-php52 .php .php4 .php3

PHP 5.3 Sürümüne geçmek için:
AddHandler application/x-httpd-php53 .php .php4 .php3

PHP 5.4 Sürümüne geçmek için:
AddHandler application/x-httpd-php54 .php .php4 .php3

PHP 5.5 Sürümüne geçmek için:
AddHandler application/x-httpd-php55 .php .php4 .php3

PHP 5.6 Sürümüne geçmek için:
AddHandler application/x-httpd-php56 .php .php4 .php3

PHP 7 Sürümüne geçmek için:
AddHandler application/x-httpd-php7 .php .php4 .php3

Size uygun kodu ekledikten sonra htaccess dosyasını kaydedip sayfanızı yineleyin.

Tekrar görüşmek üzere..

Bu Yazıyı Beğendiysen Paylaşmayı İhmal etme :)

Share on facebook
Facebook
Share on twitter
Twitter
Share on linkedin
LinkedIn

Yorum Bırakın